Home > MOSS 2007 > Stand-alone Installation Story

Stand-alone Installation Story

December 13th, 2007 Leave a comment Go to comments

It is amazing that how small things in SharePoint can turn out to be puzzling and make you scratch your head for hours. Imagine , you are installing MOSS 2007 in a stand-alone environment , easiest installation of all , right? it’s a piece of cake for you and you’re pretty confident that you can get it done in a snap. Well, you are right because you install everything in couple minutes. It is 5:30 PM and it is time to go home (For those of you who don’t start your day at 10 AM like myself and go to bed next day at 2:00 AM 😉 ).Your site comes up with no problem and last thing you would like to check is Central Administration Site. First thing that catches your eyes is that RED sign on the left side of the page saying that you are not done yet. Shoot! – Sorry , but Central admin doesn’t care that you have a wife at home, and children, and hockey match to watch, and you love your country. It keeps complaining until you FIX him!!

Okay, what’s the quickest way to get rid of this without going through administration task list?

1) Start Excel Services, WSS Search ,MOSS Search

2) Provision SSP (Shared Services)

3) STOP Excel Services, WSS Search, MOSS Search (if you don’t need em)

When you start “Windows SharePoint Services Search” , you get the following page to fill out:

 

 

 

 

You are installing this in a single server topology , so you go ahead and fill out User Name fields with a local accounts and you hit “OK”.

 

 

 

 

You get this error in 12 Hive log file:

The call to SPSearchServiceInstance.Provision (server Mossdiff’) failed. Setting back to previous status ‘Disabled’. Setting back to previous status’ Disabled ‘.

If you don’t come across this post or another hint posted somewhere, it probably takes you a while until you figure out that you have to use ComputerName\AccountName in User Name fields to get around this issue.


 

 

 

 

Same thing applies to MOSS Search settings too. Either use Computer Name\Account Name or Domain Name\Account Name. Please, please read the descriptions besides each section carefully, for some sections such as “Service Account” you shouldn’t use a built-in account (i.e. Local Service or Network Service) for security reasons and for it to access the database and content index and for some sections such as “Content Access Account” you shouldn’t use an administrator account. Those descriptions are not there to fill out the page with. They are there for us to read and decide what action to take. Another important thing here is when you set up your SSP site. When you are setting SSP , make sure that you choose the right process account for its application pool otherwise the new site you create for SSP won’t be listed under current Web Applications that you can choose for SSP. It is 8 PM and you are still at work or maybe you have read this post and I have been able to save you some time .Either case, have a good night and never underestimate SharePoint 😉

Categories: MOSS 2007 Tags:
  1. jeff
    April 23rd, 2009 at 21:33 | #1

    Thank you! -j

  2. May 22nd, 2009 at 06:35 | #2

    salam to ahle kojae ?che site khovfi dari